Последние сообщения

Страницы: [1] 2 3 ... 8
1
Интернет / Hublist Dc++ Хаблист хабы Dchublist
« Последний ответ от avatar Сентября 21, 2017, 04:18:49 pm »
Hublist Dc Хаблист хабы Dchublist

website: Hublist    *** ссылки только после регистрации или входа

Ссылка для вашего клиента:   *** ссылки только после регистрации или входа

2
Устанавливая Verlihub, можно наткнуться на неожиданные проблемы, и их решение, что и выкладываю сюда, чтобы не потерять.

В новом 9-том Debian Stretch с превеликим удивлением обнаружил, что уже нет в её репозитарии обычного всем мускула, официальное название MySQL  ;D

приходится устанавливать репазитание самого Оракла)
благо у них это автоматизировали отдельным пакетом:

Код: *** ссылки только после регистрации или входа
wget https://dev.mysql.com/get/mysql-apt-config_0.8.7-1_all.deb
устанавливаем его

Код: *** ссылки только после регистрации или входа
dpkg -i mysql-apt-config_0.8.7-1_all.deb
выбираем желаемую версию и обязательно сопутствующие мускулу библиотеки ниже оставляем Enable (:


Обнавляем репозитарии

Код: *** ссылки только после регистрации или входа
apt update
и вуаля у нас уже есть в репе mysql-server и libmysqlclient-dev mysql-client

устанавливаем все нужные пакеты для VerliHub:

Код: *** ссылки только после регистрации или входа
apt install libpcre3-dev libssl-dev mysql-server libmysqlclient-dev mysql-client g++ libgeoip-dev gettext libasprintf-dev make cmake curl python2.7-dev liblua5.2-dev lua-socket-dev libperl-dev ldconfig

так же как видим есть пакет ldconfig , он нам нужен для подкачки библиотек в папке  /usr/local/lib где будут хранится библиотеки верлика
Для этого прописываем отдельной строкой в /ldconfig.conf  и запускаем командой ldconfig для обработки

Далее уже по описанию WiKi Verlihub

смотрим все команды запуска:

Код: *** ссылки только после регистрации или входа
vh -h
запускаем установку и отладку для первого запуска:

Код: *** ссылки только после регистрации или входа
vh -i
И вперед (:

PS.  есть вариант просто установить официальную MariaBD с репозитания Debian, но тогда нада немного другие пакеты с ней ставить
Например, нада вместо libmysqlclient-dev, которого нет конечно там, ставить соответсвенно libmariadbclient-dev-compat

вот полная команда уставки с MariaBD 10.1

Код: *** ссылки только после регистрации или входа
apt install mariadb-server mariadb-client libmariadbclient-dev-compat libpcre3-dev libssl-dev g++ libgeoip-dev gettext libasprintf-dev make cmake curl python2.7-dev liblua5.2-dev lua-socket-dev libperl-dev ldconfig
все остальное должно само подтянуться зависимостями

и тоже самое... 

 ;) работает, хотя RoLeX бесится), что не поддерживаем MariaBD :)  псих одиночка, что с него возьмешь  :P
3
MikroTik CCR1009-8G-1S-1S+PC Гигабитный маршрутизатор SFP+ на 10Gbits/s
8x1Gb Ethernet CPU 9 ядер 1.2Ghz RAM 2Gb OS Level 6


MikroTik CCR1009-8G-1S-1S+PC — это маршрутизатор, в котором установлен производительный 9-ядерный процессор, 8 гигабитных сетевых портов и 2 порта для подключения оптики.

Данная модель отличается наличием пассивного охлаждения. Оно представляет собой две теплоотводные трубки, соединяющиеся с большим радиатором на задней части корпуса. Благодаря этому в помещении, в котором будет размещен роутер, будет полная тишина.

Сверху корпуса находится сенсорный экран, отображающий основные параметры маршрутизатора: загрузку процессора, сетевых портов и др.

MikroTik CCR1009-8G-1S-1S+PC можно установить на полку или в 19-дюймовый серверный шкаф или стойку с помощью креплений "ушки".

У роутера есть слот для подключения смарт-карт. С помощью смарт-карты можно хранить закрытый ключ и использовать для аутентификации.

Устройство питается от внешнего блока питания 24В 2.5A и поддерживает подачу питания по технологии Passive PoE (18-58В) через сетевой порт Eth8.

В маршрутизаторе предустановлена ОС RouterOS с лицензией Level 6, которая не имеет ограничений по ее использованию. С ее помощью вы сможете настроить ограничение скорости для пользователей, ограничение торрентов, ограничение доступа к социальным сетям, HotSpot для кафе и гостиниц, Firewall, VPN туннели, PPPoE, Proxy, FTP, Radius сервер и многое другое.

Купить MikroTik CCR1009-8G-1S-1S+PC подойдет тем, кому нужен производительный и надежный маршрутизатор для обслуживания более 200 абонентов в сети.

Характеристики:
Процессор: Tilera TILE-Gx8009 1200 MHz, 9 ядер
RAM:   2 GB DDR3 800 MHz
Flash:   128 MB Onboard NAND
Разъемы:   8 × 10/100/1000 Mbit/s Ethernet RJ45 Auto-MDI/X
1 × SFP
1 × SFP+ cage 10G (Mini-GBIC; SFP модуль не поставляется)
1 × microUSB type AB
1 × DB9 RS232C asynchronous serial port
1 × SD Card slot
1 × SmartCard slot
ОС:   MikroTik RouterOS Level6 license
Электропитание:   External 18-58V PSU included, Passive PoE input 18-58V
Размеры:   444 × 175 × 47 мм
Потребление:   ≤ 30Вт
Рабочая температура:   -20C .. +60°C

САЙТ ПРОИЗВОДИТЕЛЯ *** ссылки только после регистрации или входа

ЦЕНА 350 $

Высылаю Новой Почтой по предоплате

Звоните! торг возможен реальному покупателю!

(O63) 125-O2-O2
4
Большинство технологий VPN-шифрования разработаны Национальным Институтом Стандартов и Технологий, однако откровения Эдварда Сноудена показывают, что правительство США уже много лет пытается взломать и обойти их. Конечно же, возникает вопрос — насколько безопасны все эти способы защиты? Пришло время разобраться в них — и именно для этого мы и написали эту статью.

Прежде всего, мы разберем основные различия между протоколами VPN и тем, как они влияют на пользователей, затем перейдем к основной части, связанной с шифрованием, а также тем, как атаки на NSA могут коснуться каждого пользователя VPN.

PPTP

Этот протокол разработан ассоциацией, возглавляемой Microsoft, и представляет собой туннелирование «точка-точка», то есть создается виртуальная частная сеть внутри общей сети, этот протокол был, есть и остается стандартом VPN с момента создания. Это первый VPN-протокол, поддерживаемый Windows, безопасность обеспечивается различными методами аутентификации, например, самый распространенный из них MS_CHAP v2.

Каждое устройство, работающее с VPN, поддерживает PPTP по умолчанию, и, поскольку его очень просто настроить, этот протокол продолжает оставаться самым популярным среди владельцев компаний и VPN-провайдеров. Это также самый быстрый протокол, так как для его реализации требуется меньше всего вычислений.

Однако, хотя по умолчанию используется 128-битное шифрование, присутствуют определенные уязвимости безопасности, одна из самых серьезных — неинкапсулированная аутентификация MS-CHAP v2. Из-за этого PPTP можно взломать в течение двух дней. И хотя эта проблема была исправлена Microsoft, все же рекомендуется использовать протоколы SSTP или L2TP для повышенной безопасности.

И, конечно же, столь низкая защита PPTP обусловливает то, что расшифровка этого протокола — стандартная процедура на сегодня. Что еще больше беспокоит, так это то, что Агентство национальной безопасности США расшифровывает не только настоящий трафик, но и данные, которые были зашифрованы еще в то время, когда протокол PPTP считался безопасным.

Плюсы
  • Высокая скорость
  • Встроенный клиент практически на всех платформах.
  • Простая настройка
Минусы
  • Протокол взломан Агентством национальной безопасности США
  • Не гарантирует полную безопасность

L2TP и L2TP/IPsec

Протокол туннелирования уровня 2, в отличие от других протоколов VPN, не шифрует и не защищает данные. Из-за этого часто используются дополнительные протоколы, в частности IPSec, с помощью которого данные шифруются еще до передачи. Все современные устройства и системы, совместимые с VPN, имеют встроенный протокол L2TP/IPSec. Установка и настройка совершаются легко и не занимают много времени, однако может возникнуть проблема с использованием порта UDP 500, который блокируется файрволами NAT. Так что, если протокол используется с брандмауэром, может потребоваться переадресация портов.

Не известно о каких-либо крупных уязвимостях IPSec, и при правильном применении, этот протокол обеспечивает полную защиту конфиденциальных данных. Тем не менее, Эдвард Сноуден также отмечает, что и этот протокол не так безопасен. Джон Гилмор, основатель и специалист по безопасности Electric Frontier Roundation, заявляет, что Агентство национальной безопасности США намеренно ослабляет протокол. Более того, двукратное капсулирование данных делает протокол не столь эффективным, как, например, решения на основе SSL, но при этом он работает медленнее других протоколов.

Плюсы
  • Считаются относительно безопасными протоколами
  • Доступны в большинстве систем и почти на всех устройствах
  • Простая настройка
Минусы
  • Медленнее, чем OpenVPN
  • Защита протокола нарушена Агентством национальной безопасности США
  • Сложно использовать при наличии блокировки со стороны брандмауэра
  • Вероятнее всего, Агентство национальной безопасности США намеренно ослабляет протокол.

OpenVPN

Относительно новая технология с открытым исходным кодом, OpenVPN использует протоколы SSLv3/TLSv1 и библиотеку OpenSSL, а также некоторые другие технологии, что в целом обеспечивает надежное и мощное VPN-решение для пользователей. Протокол гибок в настройке и лучше всего работает через UDP-порт, однако его можно настроить для работы с любым другим портом, так что сервисам типа Google будет трудно их заблокировать.

Другое значимое преимущество заключается в том, что библиотека OpenSSL поддерживает различные алгоритмы шифрования, в том числе 3DES, AES, Camellia, Blowfish, CAST-128, хотя провайдеры VPN используют практически исключительно только Blowfish или AES/ По умолчанию предоставляется 128-битное шифрование Blowfish. Обычно оно считается безопасным, однако были отмечены некоторые уязвимости.

Если говорить о шифровании, AES — это самая новая технология и она считается «золотым стандартом». На данный момент не известно об уязвимостях этой системы, так что она даже используется правительством и секретными службами США для защиты данных. AES лучше справляется с объемными файлами, чем, например, Blowfish, так как размер блока составляет 128 бит, тогда как у Blowfish — 64 бита. Тем не менее, оба механизма шифрования сертифицированы NIST, а значит, существуют определенные проблемы, о которых мы поговорим далее.

Прежде всего, скорость OpenVPN зависит от уровня шифрования, хотя обычно она выше, чем у IPSec. И хотя OpenVPN — это подключение, используемое по умолчанию большинством VPN-провайдеров, оно не поддерживается на каких-либо платформах. Однако активно разрабатываются приложения от сторонних производителей, в частности для Android и iOS.

Установка чуть сложнее, чем для L2TP/IPSec и PPTP, в частности когда используется общее приложение для OpenVPN. Вам потребуется не просто скачать и установить клиент, но еще и потратить время на изменение файлов настройки. Некоторые VPN-провайдеры предлагают предварительно настроенные клиенты.

Однако, с учетом всех факторов и информации, представленной Эдвардом Сноуденом, кажется, что протокол OpenVPN является самым безопасным на данный момент. Также предполагается, что он защищен от вмешательства Агентства национальной безопасности США, так как протокол использует экспериментальные методы шифрования. Без сомнения, никто не знает всех возможностей Агентства национальной безопасности, однако, скорее всего это единственный по-настоящему безопасный протокол на сегодня.

Плюсы
  • Позволяет обходить большинство файрволов
  • Гибкая настройка
  • Открытый исходный код — может быстро адаптироваться к новым опасностям
  • Совместим с различными алгоритмами шифрования
  • Высокая степень безопасности
Минусы
  • Сложно настроить
  • Требуется стороннее ПО
  • Поддержка компьютеров неплоха, но на мобильных устройствах протокол работает не лучшим образом.

SSTP

Впервые этот протокол был представлен компанией Microsoft в SP1 для Windows Vista, на сегодня этот протокол доступен для SEIL, Linux, RouterOS, но преимущественно он рассчитан для работы в Windows. В нем используется SSL v3, так что вас ждут практически те же преимущества, что и у OpenVPN, в частности, возможность обходить файрволы NAT. SSTP — это стабильный и простой в использовании протокол, интегрированный в Windows.

Однако, всеми правами на него владеет Microsoft. Известно, что гигант индустрии активно работает со спецслужбами, кроме того, ходят слухи о том, что в систему Windows изначально встроены механизмы слежки.

Плюсы
  • Позволяет обходить большинство файрволов
  • Уровень безопасности зависит от выбранного шифра, обычно он достаточно высокий.
  • Хорошее взаимодействие с ОС Windows
  • Поддержка Microsoft
Минусы
  • Поскольку протоколом владеет компания Mirosoft, проверить или улучшить его невозможно
  • Работает только на платформе Windows

IKEv2

Это протокол туннелирования (протокол обмена ключами, версия 2), разработанный Cisco и Microsoft, он встроен в Windows 7 и последующие версии. Протокол допускает модификации с открытым исходным кодом, в частности для Linux и других платформ, также поддерживаются устройства Blackberry.

Он хорошо подходит для установки автоматического VPN-подключения, если интернет-соединение периодически разрывается. Пользователи мобильных устройств могут воспользоваться им как протоколом для беспроводных сетей по умолчанию — он очень гибок и позволяет без труда переключать сети. Кроме того, он прекрасно подойдет для пользователей Blackberry — это один из немногих протоколов, с поддержкой подобных устройств. Хотя IKEv2 доступен на меньшем количестве платформ по сравнению с, например, IPSec, он считается достаточно хорошим протоколом с точки зрения стабильности, безопасности и скорости работы.

Плюсы
  • Высокая степень безопасности — поддержка различных шифров, в частности 3DES, AES, AES 256.
  • Также поддерживает устройства Blackberry.
  • Стабильно подключается снова после разрыва соединения или смены сетей
  • Просто установить и настроить, по крайней мере, для пользователя
  • Быстрее, чем L2TP, PPTP и SSTP
Минусы
  • Поддерживает малое количество платформ.
  • Порт UDP 500 блокируется проще, чем решения на основе SSL, как, например, SSTP или OpenVPN
  • Исходный код не открыт
  • Установка на сервер довольно трудная, это может вызвать потенциальные проблемы

Проблемы

Чтобы понять то, как происходит шифрование, вам нужно разобраться в некоторых важных понятиях, которые мы рассмотрим далее.

Длина ключа шифрования

Самый грубый способ понять, сколько времени потребуется, чтобы дешифровать данные — это длина ключа, это ряды нулей и единиц, используемые в шифре. При подборе методом «brute force» выполняется самая прямолинейная попытка дешифровать ключ — проверяются все доступные комбинации, пока не будет найдена соответствующая. Обычно длина ключа для VPN составляет от 128 до 256 бит. Более высокие уровни используются для аутентификации, однако означает ли то, что шифр 256-бит лучше, чем шифр 128-бит?

Давайте разберемся и посчитаем:
  • Чтобы взломать 128-битный шифр, потребуется 3,4×10(38) операций.
  • Естественно, чтобы взломать 256-битный шифр, необходимо в 2(128) раз больше вычислений.
  • Подбор 256-битного шифра потребует 3.31 x 10(65) операций, что примерно равно количеству атомов во вселенной.
  • Самый быстрый компьютер 2011 года Фуджитсу К работает со скоростью до 10.51 петафлопс. У него подбор ключа AES 128-бит займет порядка миллиарда лет.
  • NUDT Tianhe-2, самый мощный суперкомпьютер 2013 года, работает со скоростью до 33,86 петафлопс. Это почти в три раза быстрее, чем Фуджитсу К, так что у него это займет всего лишь треть миллиарда лет.

До того, как Эдвард Сноуден озвучил свои откровения, многие считали даже 128-битный шифр достаточной защитой, и что в ближайшие сто лет ключ к нему не будет подобран. Однако, с учетом того, какие ресурсы находятся в распоряжении Агентства национальной безопасности, многие системные администраторы рекомендуют увеличить длину ключа. Нелишним будет отметить, что правительство США использует 256-битное шифрование для защиты важных данных (для стандартных данных используется 128-битное). Тем не менее, даже с учетом этих надежных методов шифрования, AES может вызвать определенные проблемы

Шифры

Шифры — это математические алгоритмы, используемые в процессе шифрования, более простые из них уязвимы для хакеров, так как позволяют дешифровать данные без труда. На сегодня самые известные и распространенные шифры — это AES и Blowfish, их можно встретить в большинстве VPN. Кроме того, для шифрования и дешифровки используется RSA, тогда как SHA-1 и SHA-2 применяются при аутентификации и хэшировании.

Однако, наиболее безопасным шифром для VPN считается AES, особенно характерно то, что именно этим шифрованием пользуется правительство США. Тем не менее, есть определенные причины сомневаться в надежности этого шифра.

Национальный институт стандартов и технологии (НИСТ)

SHA-1, SHA-2, RSA и AES — все они сертифицированы Национальным институтом стандартов и технологии США, который тесно сотрудничает с Агентством национальной безопасности в разработке шифров. Однако теперь мы знаем, что власти и спецслужбы США пытаются намеренно ослабить алгоритмы шифрования или внедрить уязвимости, так что возникает вопрос, настолько ли честна работа НИСТ.

Конечно же, сам Институт отрицает, что существуют какие-либо проблемы (в частности, намеренное ослабление стандартов шифрования) и пытается успокоить людей, Агентство национальной безопасности несколько раз обвиняли, например, New York Times, в том, что они вмешиваются в процесс разработки или же преднамеренно включают определенные уязвимости, призванные ослабить алгоритмы шифрования.

17 сентября 2013 года недоверие возросло еще сильнее, когда RSA Security порекомендовали своим пользователям воздержаться от использования конкретного алгоритма, содержащего уязвимости, намеренно внедренные в него Агентством национальной безопасности США.

Более того, выяснилось, что стандарт, разработанный НИСТ, Dual EC DRBG, многие годы был небезопасен. Это было отмечено Университетом технологии в Нидерландах в 2006 году. Однако, несмотря на все эти проблемы и сложности, НИСТ является лидером в индустрии, в том числе и из-за того, что соответствие стандартам НИСТ является обязательным условием для получения контракта с правительством США.

Стандарты НИСТ используются по всему миру, во всех сферах бизнеса и производства, где необходима защита личных данных, в частности, в индустрии VPN, — и эти проблемы являются значимыми для всех. Многие производители полагаются на эти стандарты и не желают признавать проблему. Единственная компания, Silent Circle, закрыла свой сервис Silent Mail, вместо того, чтобы позволить скомпрометировать его, затем они отошли от стандартов НИСТ в ноябре 2013 года.

Благодаря подобным действиям от BestVPN, небольшого провайдера, известного своими инновациями, LiquidVPN запустили тестирование новых алгоритмов, не связанных с НИСТ. Однако, это единственный провайдер, работающий в данном направлении, о котором нам известно. Конечно же, пока не произойдет серьезных изменений, вам нужно по полной использовать шифрование AES 256 бит, которое на сегодня является лучшим из доступных.

Попытки взлома шифрования RSA Key Агентством национальной безопасности США
Эдвард Сноуден рассказал также о том, что была разработана новая программа «Cheesy Name», направленная на определение клчей шифрования, которые могут быть взломаны суперкомпьютерами в Штабе правительственной связи. Оказывается, что сертификаты, защищенные 1024-битным шифрованием, слабее, чем предполагалось, их можно достаточно быстро дешифровать, намного бытрее, чем ожидалось. После того, как шифр будет взломан, это коснется всех пользователей, так как можно будет дешифровать все данные.

Вследствие этого, будут взломаны системы шифрования, основанные на подобных ключах, в том числе и TLS и SSL. Это очень сильно повлияет на трафик HTTPS. Однако, есть и хорошие новости. OpenVPN это не коснется, так как протокол меняет временные ключи шифрования. Почему? Для каждого обмена данными генерируется новый ключ.

Даже если кто-то получил ключ к сертификату, дешифровать все данные невозможно. При атаке «человек посередине» (MitM) возможно взломать соединение OpenVPN, однако нужно получить доступ к ключу. С момента, как стало известно об уязвимостях в 1024-битном шифровании, многие провайдеры перешли на 2048- или даже 4096-бит.

Совершенная прямая секретность

Хорошие новости — есть решение даже этих проблем, в том числе и для соединения TLS и SSL, если сайты используют системы прямой секретности, в которых для каждой сессии генерируется уникальный новый ключ. К сожалению, единственная компания, применяющая механизм совершенной прямой секретности — это Google.

В завершение этой статьи хотелось бы напомнить слова Эдварда Сноудена, — шифрование работает и системы шифрования будут улучшены, чтобы повысить безопасность. Что же вы можете вынести из этой статьи? Очень просто! Самый безопасный протокол VPN — это OpenVPN, соответственно провайдерам нужно расширять сферу его применения. Было бы неплохо, если бы они начали отходить от стандартов НИСТ, однако этого придется подождать.

  • PPTP — очень небезопасный протокол. Его взломали спецслужбы и даже Microsoft отказались от его поддержки, так что на сегодня следует его избегать. И хотя вас может привлечь удобство настройки или кросс-платформенная совместимость, помните, что практически те же преимущества предлагает L2TP/IPSec, однако у него еще и более высокий уровень защиты.
  • Если речь не идет о действительно важных данных, L2TP/IPSec — это то, что вам нужно, хотя этот протокол и ослаблен и скомпрометирован. Однако, если вы ищете быстрый и удобный в настройке VPN, который не требует установки дополнительного ПО, он прекрасно подойдет, особенно с учетом того, что VPN для мобильных устройств поддерживается не лучшим образом.
  • Несмотря на то, что вам нужно будет устанавливать сторонние приложения, OpenVPN — лучший протокол в любом случае. Он работает быстро, надежно, и, хотя его настройка может занять немало времени, она того стоит.
  • KEv2 тоже работает быстро и безопасно, и если он используется в сочетании с другими средствами обеспечения безопасности, он может прекрасно подойти для пользователей мобильных устройств, в частности благодаря автоматическому возобновлению подключения. Кроме того, это один из немногих протоколов с поддержкой устройств Blackberry.
  • SSTP предлагает практически те же преимущества, что и OpenVPN, однако он работает только на платформе Windows. С другой стороны, он куда лучше совместим с этой системой, чем другие протоколы. Однако, поддержка провайдеров ограничена, во-первых, из-за поддержки систем, во-вторых, из-за того, что компания Microsoft известна давним сотрудничеством с Агентством национальной безопасности, так что мы бы не советовали доверять этому протоколу.

Если кратко, при возможности используйте OpenVPN, для мобильных устройств подойдет IKEv2. L2TP — этого протокола достаточно для быстрых решений, однако с учетом расширения поддержки OpenVPN для разных устройств, мы рекомендуем его в любой ситуации.
5
Обход блокировки сайтов на Mikrotik при помощи Policy Based Routing.

Сегодня мы не будем рассматривать все методы обхода всех видов блокировки, а лишь рассмотрим один из вариантов реализации обхода, который предложен в официальной документации Mikrotik (Policy Based Routing).

Предполагается, что заранее у вас уже должен быть маршрутизатор на RouterOS, если такого не имеется - по выгодной цене маршрутизаторы Mikrotik можно приобрести у меня!

Наиболее простой вариант обхода – использовать серверы VPN. Причем заблокированные ресурсы можно открывать через VPN, а все оставшиеся – через провайдера.
У данного метода существует ряд преимуществ. Одно из главных достоинств данного метода состоит в том, что вы будете использовать лишь часть пропускной способности VPN. Дело в том, что сервисы VPN обычно находятся далеко заграницей и каналы к ним сильно загружены, поэтому направляя через тоннель весь трафик, скорость доступа будет падать, причем как для заблокированных ресурсов, так и для всех остальных.
Из дополнительных преимуществ данного метода можно отметить отсутствие необходимости настройки VPN на всех клиентских устройствах, особенно если это смартфон. Хотя для смартфонов существует достаточное количество бесплатных приложений, реализующих необходимый функционал. Есть у данного способа и недостаток – поиск оптимального VPN-сервиса, как вариант, покупка премиум-аккаунта.

Создание списка адресов
К примеру, у нас есть листинг из заблокированных адресов. В качестве примера у нас 4 списка: ВКонтакте, Одноклассники, Yandex и Mail.ru. Все диапазоны в виде команд для Mikrotik, для простоты добавление. Некоторые спросят, а почему не объединить все ресурсы в один список? Ответ очень простой, при изменении всего одного интернет-ресурса, вы будете вынуждены пересматривать весь список, т.к. по одним подсетям вы ориентироваться будет сложно.
Адреса можно добавлять как вручную через терминал из WinBox > New Terminal.

Список подсетей для ресурсов ВКонткте
Код: *** ссылки только после регистрации или входа
/ip firewall address-list
add address=87.240.128.0/18 list=vkcom add address=93.186.224.0/20 list=vkcom add address=95.142.192.0/20 list=vkcom
add address=95.213.0.0/17 list=vkcom add address=185.32.248.0/22 list=vkcom add address=95.213.0.0/18 list=vkcom
add address=95.142.207.0/24 list=vkcom add address=95.142.206.0/24 list=vkcom add address=95.142.204.0/23 list=vkcom
add address=95.142.203.0/24 list=vkcom add address=95.142.202.0/24 list=vkcom add address=95.142.201.0/24 list=vkcom
add address=95.142.200.0/21 list=vkcom add address=95.142.192.0/21 list=vkcom add address=93.186.232.0/21 list=vkcom
add address=93.186.224.0/21 list=vkcom add address=185.32.251.0/24 list=vkcom add address=185.32.250.0/24 list=vkcom
add address=185.32.248.0/23 list=vkcom add address=185.29.130.0/24 list=vkcom

Либо предварительно загрузив в память микротика необходимые списки в виде командных файлов с разрешением RSC. Файлы в Mikrotik загружаются путем обычного петаскивания на окно WinBox > Files. Или же при помощи кнопки Upload, если Drag-n-Drop по каким-то причинам не работает. После чего импортируете списки командой:
Код: *** ссылки только после регистрации или входа
import file=vkcom.rsc
Где vkcom.rsc - название файла со списком.   Скачать список для Вконтакте - *** ссылки только после регистрации или входа

Список подсетей для ресурсов Яндекса (в т.ч. КиноПоиск)  Скачать список для Яндекса -*** ссылки только после регистрации или входа
Код: *** ссылки только после регистрации или входа
/ip firewall address-list
add address=5.45.192.0/18 list=yandex add address=5.255.192.0/18 list=yandex add address=37.9.64.0/18 list=yandex
add address=37.140.128.0/18 list=yandex add address=77.88.0.0/18 list=yandex add address=84.201.128.0/18 list=yandex
add address=87.250.224.0/19 list=yandex add address=93.158.128.0/18 list=yandex add address=95.108.128.0/17 list=yandex
add address=100.43.64.0/19 list=yandex add address=130.193.32.0/19 list=yandex add address=141.8.128.0/18 list=yandex
add address=178.154.128.0/17 list=yandex add address=199.21.96.0/22 list=yandex add address=199.36.240.0/22 list=yandex
add address=213.180.192.0/19 list=yandex add address=93.158.134.0/24 list=yandex add address=87.250.255.0/24 list=yandex
add address=87.250.254.0/24 list=yandex add address=87.250.251.0/24 list=yandex add address=87.250.250.0/24 list=yandex
add address=87.250.247.0/24 list=yandex add address=77.88.8.0/24 list=yandex add address=77.88.55.0/24 list=yandex
add address=77.88.54.0/24 list=yandex add address=77.88.44.0/24 list=yandex add address=77.88.35.0/24 list=yandex
add address=77.88.21.0/24 list=yandex add address=77.75.159.0/24 list=yandex add address=77.75.152.0/22 list=yandex
add address=5.45.240.0/24 list=yandex add address=5.45.232.0/24 list=yandex add address=5.45.229.0/24 list=yandex
add address=5.45.217.0/24 list=yandex add address=5.45.213.0/24 list=yandex add address=5.45.205.0/24 list=yandex
add address=5.45.196.0/24 list=yandex add address=5.255.255.0/24 list=yandex add address=5.255.200.0/24 list=yandex
add address=5.255.196.0/24 list=yandex add address=5.255.195.0/24 list=yandex add address=37.9.112.0/24 list=yandex
add address=213.180.204.0/24 list=yandex add address=213.180.202.0/24 list=yandex add address=213.180.199.0/24 list=yandex
add address=213.180.193.0/24 list=yandex add address=185.71.79.0/24 list=yandex add address=185.71.78.0/24 list=yandex
add address=185.71.77.0/24 list=yandex add address=185.71.76.0/24 list=yandex add address=185.71.76.0/22 list=yandex
add address=185.32.186.0/24 list=yandex add address=185.32.185.0/24 list=yandex add address=178.154.170.0/24 list=yandex
add address=178.154.131.0/24 list=yandex add address=109.235.165.0/24 list=yandex add address=109.235.160.0/21 list=yandex
add address=100.43.87.0/24 list=yandex

Список подсетей для Одноклассники.ru   Скачать список для Одноклассников - *** ссылки только после регистрации или входа
Код: *** ссылки только после регистрации или входа
/ip firewall address-list
add address=5.61.16.0/21 list=okru add address=5.61.232.0/21 list=okru add address=79.137.157.0/24 list=okru
add address=79.137.183.0/24 list=okru add address=94.100.176.0/20 list=okru add address=95.163.32.0/19 list=okru
add address=128.140.168.0/21 list=okru add address=178.22.88.0/21 list=okru add address=178.237.16.0/20 list=okru
add address=185.5.136.0/22 list=okru add address=185.6.247.0/24 list=okru add address=185.16.244.0/22 list=okru
add address=188.93.56.0/21 list=okru add address=194.186.63.0/24 list=okru add address=195.211.20.0/22 list=okru
add address=195.218.168.0/24 list=okru add address=195.218.190.0/23 list=okru add address=217.20.144.0/20 list=okru
add address=217.69.128.0/20 list=okru

Список подсетей для ресурсов Mail.ru   Скачать список для MailRU - *** ссылки только после регистрации или входа
Код: *** ссылки только после регистрации или входа
/ip firewall address-list
add address=5.61.16.0/21 list=mailru add address=5.61.232.0/21 list=mailru add address=79.137.157.0/24 list=mailru
add address=79.137.183.0/24 list=mailru add address=94.100.176.0/20 list=mailru add address=95.163.32.0/19 list=mailru
add address=128.140.168.0/21 list=mailru add address=178.22.88.0/21 list=mailru add address=178.237.16.0/20 list=mailru
add address=185.5.136.0/22 list=mailru add address=185.6.247.0/24 list=mailru add address=185.16.244.0/22 list=mailru
add address=188.93.56.0/21 list=mailru add address=194.186.63.0/24 list=mailru add address=195.211.20.0/22 list=mailru
add address=195.218.168.0/24 list=mailru add address=195.218.190.0/23 list=mailru add address=217.20.144.0/20 list=mailru
add address=217.69.128.0/20 list=mailru add address=195.211.21.0/24 list=mailru add address=195.211.22.0/24 list=mailru
add address=195.211.20.0/24 list=mailru add address=208.87.94.0/24 list=mailru add address=195.211.130.0/23 list=mailru
add address=195.211.128.0/24 list=mailru add address=195.211.128.0/23 list=mailru add address=195.211.128.0/22 list=mailru
add address=185.16.244.0/23 list=mailru add address=185.16.148.0/22 list=mailru add address=128.140.170.0/24 list=mailru

Списки адресов находятся в разделе IP – Firewall – Address Lists.



Маркировка пакетов
Для того, чтобы отобрать только заблокированные ресурсы, необходимо найти и промаркировать необходимые пакеты.
Делается это в IP – Firewall – Mangle. При создании указываем следующие параметры: chain=prerouting action=mark-routing dst-address-list=mailru (список адресов) src-address=192.168.106.0/24 (локальная подсеть) Вместо 192.168.106.0/24 необходимо указывать свою локальную подсеть, из которой будут идти обращения.

Как несложно догадаться, dst-address-list это конечный адрес (из списка).

Для всего трафика, удовлетворяющего данным условиям, будет установлена соответствующая метка Traffic_XXXXX.

Код: *** ссылки только после регистрации или входа
/ip firewall mangle
add action=mark-routing chain=prerouting comment="Mark mail.ru" dst-address-list=mailru new-routing-mark=Traffic_mailru passthrough=no src-address=192.168.106.0/24
add action=mark-routing chain=prerouting comment="Mark ok.ru" dst-address-list=okru new-routing-mark=Traffic_okru passthrough=no src-address=192.168.106.0/24
add action=mark-routing chain=prerouting comment="Mark vk.com" dst-address-list=vkcom new-routing-mark=Traffic_vkcom passthrough=no src-address=192.168.106.0/24
add action=mark-routing chain=prerouting comment="Mark Yandex" dst-address-list=yandex new-routing-mark=Traffic_yandex passthrough=no src-address=192.168.106.0/24

Создание VPN-подключения
В качестве примера воспользуемся бесплатным сервисом VPN PPTP – uFreeVPN.

Для примера выберем сервер, расположенный в Лондоне (Великобритания) – *** ссылки только после регистрации или входа, логин ufreevpn.com, пароль free.

Минусом конкретно данного сервиса является то, что он постоянно меняет пароли для подключения к серверу, мы же используем его исключительно в качестве примера.

Создание подключения к VPN осуществляется в разделе PPP – Interface, нажимаем синий плюс и выбираем необходимый тип подключения.

Код: *** ссылки только после регистрации или входа
/interface pptp-client
add comment="VPN Failover" connect-to=ukvpn.ufreevpn.com disabled=no name=pptp-to-freevpn password=free user=ufreevpn.com

Важно! Не используйте опцию «Add Default Route», в противном случае весь трафик пойдет через VPN.

Обратите внимание, некоторые серверы могут, как требовать шифрование, так и не использовать его вовсе, поэтому если соединение не удалось – проверьте используемый профиль подключения (PPP – Profiles). Для L2TP, в лучшем случае, используется MPPE 128-bit, который уже давным-давно скомпрометирован.

Лучшим вариантом будет использование OpenVPN, в частности с премиум-аккаунтом. Также не забывайте, что RouterOS не поддерживает пока TLS для OpenVPN.

Большинство бесплатных серверов могут быть нестабильны как в плане доступности, так и в плане скорости. К тому же, никто не гарантирует сохранности ваших личных данных. С учетом вышесказанного, к выбору поставщика услуг стоит подойти ответственно. Как минимум, всегда используйте защищенное соединение (HTTP) при работе с сайтами.

Настройка маскарадинга
Сам Mikrotik уже знает про новый шлюз, а для того, чтобы ресурсами VPN-канала смогли пользоваться другие пользователи локальной сети, необходимо настроить маскарадинг.

Делается это в разделе IP – Firewall – NAT. Для out-interface обязательно следует указать правильное название вашего VPN-подключения.

Код: *** ссылки только после регистрации или входа
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pptp-to-freevpn

Добавление статических маршрутов
После настройки маскарадинга переходим к завершающему шагу – созданию статических маршрутов. Делается это в разделе IP – Routers.

Код: *** ссылки только после регистрации или входа
/ip route
add comment="Route MAIL.RU" distance=1 gateway=pptp-to-freevpn routing-mark=Traffic_mailru
add comment="Route OK.RU" distance=1 gateway=pptp-to-freevpn routing-mark=Traffic_okru
add comment="Route VK.COM" distance=1 gateway=pptp-to-freevpn routing-mark=Traffic_vkcom
add comment="Route YANDEX" distance=1 gateway=pptp-to-freevpn routing-mark=Traffic_yandex

При создании маршрутов конечный адрес задаем как и для обычного интернет подключения –0.0.0.0/0, в качестве шлюза (gateway) необходимо указать VPN-подключение (в нашем случае pptp-to-freevpn). Обязательно выбираем routing-mark из выпадающего списка. Таким образом мы создаем статический маршрут для промаркированного трафика.



Вот собственно и всё, если всё проделано верно, а VPN рабочий – вы сможете получить доступ к необходимым ресурсам.
Также можете почитать официальную документацию Mikrotik по Policy Base Routing.

Как узнать IP определенного сайта?
Чуть выше, в качестве примера, опубликованы общие списки IP-адресов и диапазонов, принадлежащих соответствующим ресурсам. Списки предоставлен как есть, без претензий к их точности. Настоятельно рекомендую формировать список самостоятельно, так сказать «под себя».
В случае с обычными интернет-сайтам, обычно требуется добавить всего 1-2 IP-адреса, в то время как для больших проектов может использоваться несколько диапазонов. Как же найти все IP по определенному сайту?

В качестве наиболее простого варианта, из под Windows (вызов командной строки – комбинация Win+R) можно использовать стандартную команду:

Код: *** ссылки только после регистрации или входа
nslookup <домен>
Недостатком такого метода является получение неполного списка адресов.
Для поиска наиболее полного списка всех адресов, можно *** ссылки только после регистрации или входа. При помощи поиска от Hurricane Electric, можно производить поиск, как по доменному домену (например, youtube.com), так и по названию компании, которая владеет пулом адресов (например, Youtube либо YouTube, LLC).


Редактирование, обновление и добавление новых ресурсов
Еще одним неоспоримым преимществом раздельных списков является то, что в любой момент можно добавлять, удалять или изменять отдельные списке, при этом остальные ресурсы не будут затронуты.

Список подсетей для Лаборатории Касперского  Скачать список для Kaspersky Lab - *** ссылки только после регистрации или входа

Код: *** ссылки только после регистрации или входа
/ip firewall address-list
add address=93.159.230.0/23 list=kaspersky add address=93.159.228.0/23 list=kaspersky
add address=93.159.224.0/22 list=kaspersky add address=91.103.64.0/21 list=kaspersky add address=77.74.183.0/24 list=kaspersky
add address=77.74.180.0/22 list=kaspersky add address=77.74.178.0/23 list=kaspersky add address=77.74.177.0/24 list=kaspersky
add address=77.74.176.0/24 list=kaspersky add address=185.85.15.0/24 list=kaspersky add address=185.85.14.0/24 list=kaspersky
add address=185.85.12.0/24 list=kaspersky add address=185.54.221.0/24 list=kaspersky add address=185.54.220.0/24 list=kaspersky

Ну и, конечно же, чтобы начать обработку нового списка, необходимо создать новый мангл (промаркировать пакеты) и статический маршрут для нового списка (общий принцип описан выше).

Что делать, если Policy Based Routing медленно работает?
На некоторых конфигурациях может возникнуть проблема, суть которой состоит в том, что при прямом подключении по VPN на ПК – всё работает быстро, но если настроить Policy Based Routing по вышеуказанному примеру в Mikrotik, сайты начинают открываются медленно.

Проблема решается отключением FastTrack в IP – Firewall – Filter Rules.





Поддержка FastTrack была добавлена, начиная с RouterOS 6.29, если кратко, функция позволяет пересылать некоторые пакеты без дополнительно обработки. В некоторых конфигурациях, данная функция позволяет существенно (в несколько раз) ускорить обработку пакетов и понизить нагрузку на процессор.

Источник: *** ссылки только после регистрации или входа
6
Шаг 1 - Запускаем WinBox и подключаемся к маршрутизатору Mikrotik Route Board

Шаг 2 - Выбираем пункт New Terminal

Шаг 3 - Копируем скрипт

/ip firewall filter

Код: *** ссылки только после регистрации или входа
add chain=forward protocol=tcp dst-port=22,2022 src-address-list=ssh_blacklist action=drop comment="drop ssh brute forcers" disabled=no
add chain=forward protocol=tcp dst-port=22,2022 connection-state=new src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist address-list-timeout=3h comment="" disabled=no
add chain=forward protocol=tcp dst-port=22,2022 connection-state=new src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3 address-list-timeout=1m comment="" disabled=no
add chain=forward protocol=tcp dst-port=22,2022 connection-state=new src-address-list=ssh_stage1 action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment="" disabled=no
add chain=forward protocol=tcp dst-port=22,2022 connection-state=new action=add-src-to-address-list address-list=ssh_stage1 address-list-timeout=1m comment="" disabled=no

Шаг 4 - Вставляем скрипт в Терминальное окно и жмем Enter

Это пример для SSH на 22 и 2022 порту, после 3-x соединений за минуту четвертое загоняет ip нашего страдальца в бан на 3 часа (3h)  :)

Так же можно любой порт ограничить или множество портов!
8
Mini-PCI WiFi 2.4/5GHz карта Mikrotik R52n-M a/g/n 300Mb/s 200мВт 23dBm

RouterBOARD R52nM – беспроводной miniPCI адаптер, работающий на частотах 2,4 ГГц или 5 ГГц с мощностью 23 дБм (200 мВт). Сетевой адаптер поддерживает работу в стандартах IEEE 802.11a/b/g/n с канальной скоростью до 300 Мбит/с. Фактическая пропускная способность R52nM составляет 200 Мбит/с на загрузку и отдачу.

Сетевую Wi-Fi карту MikroTik R52n-M используют с роутерами MikroTik для создания беспроводных точек доступа, построения Wi-Fi соединений «точка-точка», подключения к беспроводным базовым станциям. Сетевая карта подключается в разъем miniPCI роутера MikroTik, и роутер получает приемник/передатчик Wi-Fi. К MMCX разъемам R52nM подключаются переходники (пигтейлы) для соединения с внешними антеннами. Таким образом, вы собираете Wi-Fi устройство с необходимой конфигурацией под вашу задачу.

Чтобы обеспечить высокую пропускную способность, Wi-Fi адаптер R52nM необходимо использовать с двухполяризационными MIMO антеннами. Для подключения таких антенн на Wi-Fi карте расположены два MMCX разъема повышенной прочности.

Если вы проектируете беспроводную сеть на базе роутеров MikroTik, то для создания высокоскоростного канала связи понадобится купить RouterBOARD R52n-M.

Характеристики
Система
Формат:   miniPCI
Стандарты:   802.11a/b/g/n
Частоты:   2,4 и 5 ГГц
Chipset:   AR9220
Выходная мощность:   23 dBm
Антенные разъемы:   2 × MMCX
Модуляция:   OFDM: BPSK, QPSK, 16 QAM, 64QAM;
DSSS: DBPSK, DQPSK, CCK
Другое
Поддержка:   2×2 MIMO
Совместимость:   RouterOS
Рабочая температура:   от -50°C до +70°C

Детальнее читайте тут  *** ссылки только после регистрации или входа
Сайт производителя *** ссылки только после регистрации или входа

Пересылка и оплата в др города по Новой Почте.
Самовывоз с Нагорки. Возле танка c 10:00 до 20:00 

ЦЕНА 490 грн

Звоните! торг возможен реальному покупателю!

(O63) 125-O2-O2
9
Остановись и гори / Замри и гори / Halt and Catch Fire (2016) WEB-DLRip
(Сезон 3, Серии 1-10 из 10) NewStudio




Год выпуска: 2016
Страна: США
Жанр: драма

Перевод: Многоголосый закадровый, профессиональный - NewStudio


Режиссер: Хуан Хосе Кампанелла
В ролях: Ли Пейс, Скут МакНэйри, Маккензи Дэвис, Керри Бише, Тоби Хасс и др.

Описание фильма:
Сюжет разворачивается в 1980-х. Сериал рассказывает о компьютерном буме от лица мечтателя, инженера и вундеркинда, чьи инновации столкнулись с корпоративными гигантами того времени.

Продолжительность: ~00:43:00 серия
Качество видео: WEB-DLRip

Видеокодек: XviD
Формат: AVI
Битрейт видео: ~1453 kb/s
Размер кадра: 720х400 (16:9)
Аудио Rus Image: (MPEG Layer 3, 48,0 kHz, 2 ch, 128 kb/s) - многоголосый закадровый
Аудио Eng Image: (MPEG Layer 3, 48,0 kHz, 2 ch, 128 kb/s) - оригинал

*** ссылки только после регистрации или входа   (541,6 MБ)
*** ссылки только после регистрации или входа   (542,9 MБ)
*** ссылки только после регистрации или входа   (541,4 MБ)
*** ссылки только после регистрации или входа   (541,1 MБ)
*** ссылки только после регистрации или входа   (689,9 MБ)
*** ссылки только после регистрации или входа   (540,2 MБ)
*** ссылки только после регистрации или входа   (540,2 MБ)
*** ссылки только после регистрации или входа   (538,9 MБ)
*** ссылки только после регистрации или входа   (541,3 MБ)
*** ссылки только после регистрации или входа   (541,5 MБ)
10
Система / ОС OS X: функция Gatekeeper "Программа повреждена и не может…"
« Последний ответ от Дмитрий Сентября 26, 2016, 03:52:15 pm »
"Программа повреждена и не может…"

ОС OS X: функция Gatekeeper
Параметры функции Gatekeeper находятся в меню Apple > Системные настройки… > Защита и безопасность > вкладка «Основные» под заголовком «Разрешать загрузки программ из:»



macOS Sierra 10.12

***** если в 10.12 в настройках «Защита и безопасность» нет пункта «Разрешить использование программ, загруженных из: любого источника»
a) Cнятие карантина для указанного приложения (работает не всегда)
- открываем терминал
- копируем код и вставляем в открытое окно терминала
Код: *** ссылки только после регистрации или входа
sudo xattr -rd com.apple.quarantine /Applications/ваша программа- ставим пробел, перетаскиваем иконку нужной программы в окно терминала и нажимаем Enter

b) После выполнения в терминале команды, указанной ниже в «системные настройки - > защита и безопасность -> основные» появится пункт Разрешить использование программ, загруженных их «Любого источника» (команда выполняется единожды)
Код: *** ссылки только после регистрации или входа
sudo spctl --master-disable
Более подробная информация *** ссылки только после регистрации или входа
Страницы: [1] 2 3 ... 8